Catalyst for … (social change) … fedora 10 and kernel 2.6.29 with fglrx catalyst 9.3 / 9.4 / 9.5

Getting the fglrx proprietary driver up adn running on Fedora 10 i386 seems a pain.When paired with a Sceptre X22WG ( a 22″ 1680×1050 monitor with VGA, DVI and HDMI inputs ) seems an even bigger headache.

When you update to kernel 2.6.29 , be warned that the Catalyst drivers are yet to do so!

Get info on the patch at the Archlinux forums at http://aur.archlinux.org/packages.php?ID=15482&detail=0

Patch: http://aur.archlinux.org/packages/catalyst-ice/catalyst-ice/2.6.29.diff

Get your catalyst drivers at this link: http://support.amd.com/us/gpudownload/linux/previous/Pages/radeon_linux.aspx

* You need the kernel sources / headers present for this to build

* Run ./ati-driver-installer-xxxxxxxxxxx.run to install the driver

* Check the driver install log at /usr/share/ati/fglrx-install.log . It will probably mention that the kernel module could not be built.

* Copy the patch 2.6.29.diff to / .  run:   patch -p0 < 2.6.29.diff . This will patch the driver files at /lib/modules/fglrx/build_mod .

* Next run make.sh from /lib/modules/fglrx/build_mod . If the build succeeds, run make_install.sh from /lib/modules/fglrx .

Go be the catalyst!

I was able to set my Asus M2A-VM (690G) to drive 1680×1050 over VGA and DVI  to the Sceptre 22″ X22WG .

Update: This works on my Spanking new XFX Radeon HD 4770 with catalyst 9.5 as well!

Advertisements

Tags: , , , , , , , , , , , , , , ,

4 Responses to “Catalyst for … (social change) … fedora 10 and kernel 2.6.29 with fglrx catalyst 9.3 / 9.4 / 9.5”

  1. hanbin Says:

    I’m using ubuntu.

    I tried your steps but … It failed.

    I;m 9.04 jaunty.

    What ever , the reason was , there was no such folder called fglrx in /lib/modules…

  2. activity Says:

    Ubuntu jaunty ships with fglrx 9.4 . You need 9.3 for some reason ? Then check the installer logs and find the path where the module is installed!

  3. hanbin Says:

    I mean I’m trying to configure 2.6.29 kernel with jaunty and fglrx 9.4.

  4. jonaternet Says:

    Hello,
    Activity said “You need 9.3 for some reason ? ”
    Thousands people need the 9.3 driver and only this one, because their card won’t run with the >=9.4 driver : nearly all the cards more than two or thre years old, like for example my Radeon 9600 AGP. It’s a shame, we have been abandoned by ATI and fglrx developpers.
    So… All the users of recent linux distributions can’t have it running, because fglrx’s old versions are not compatible with newest X.org versions… The more time passes, the more it becomes difficult to make it work. If I am wrong, tell me, I would be very happy to be wrong !
    I ‘m actually trying to create a script for it, but I can’t find the right way to do. I only know the shell scripting language, so there are lots of things I don’t understand. any help would be helpfull.
    So, I will try to adapt your technic to my system -Ubunut 9.10 AMD64 with 2.6.31 kernel-
    because it may be the only one I havent tested yet….
    I will soon post a link to the script.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: