Posts Tagged ‘2.6.29’

Catalyst for … (social change) … fedora 10 and kernel 2.6.29 with fglrx catalyst 9.3 / 9.4 / 9.5

April 19, 2009

Getting the fglrx proprietary driver up adn running on Fedora 10 i386 seems a pain.When paired with a Sceptre X22WG ( a 22″ 1680×1050 monitor with VGA, DVI and HDMI inputs ) seems an even bigger headache.

When you update to kernel 2.6.29 , be warned that the Catalyst drivers are yet to do so!

Get info on the patch at the Archlinux forums at http://aur.archlinux.org/packages.php?ID=15482&detail=0

Patch: http://aur.archlinux.org/packages/catalyst-ice/catalyst-ice/2.6.29.diff

Get your catalyst drivers at this link: http://support.amd.com/us/gpudownload/linux/previous/Pages/radeon_linux.aspx

* You need the kernel sources / headers present for this to build

* Run ./ati-driver-installer-xxxxxxxxxxx.run to install the driver

* Check the driver install log at /usr/share/ati/fglrx-install.log . It will probably mention that the kernel module could not be built.

* Copy the patch 2.6.29.diff to / .  run:   patch -p0 < 2.6.29.diff . This will patch the driver files at /lib/modules/fglrx/build_mod .

* Next run make.sh from /lib/modules/fglrx/build_mod . If the build succeeds, run make_install.sh from /lib/modules/fglrx .

Go be the catalyst!

I was able to set my Asus M2A-VM (690G) to drive 1680×1050 over VGA and DVI  to the Sceptre 22″ X22WG .

Update: This works on my Spanking new XFX Radeon HD 4770 with catalyst 9.5 as well!